Temporary delay in account verification
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 14:04 EEST
Investigating
We are currently experiencing delays with our verification process due to a third-party service issue. This may impact customers needing to verify or re-verify their accounts.
Our team is actively working to resolve the issue as quickly as possible. We appreciate your patience and understanding.
Posted Sep 30, 2024 - 16:32 EEST
This incident affected: Account Registration & Identification.