A small amount of Finnish customers are not able to complete personal verification with Tupas
Incident Report for Holvi Payment Services Oy
Resolved
This issue has been fixed.
Posted Dec 17, 2019 - 12:51 EET
Update
We are continuing to work on a fix for this issue.
Posted Dec 17, 2019 - 08:29 EET
Update
We are continuing to work on a fix for this issue.
Posted Dec 16, 2019 - 16:23 EET
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 16, 2019 - 12:10 EET
Update
We are continuing to investigate this issue.
Posted Dec 16, 2019 - 09:17 EET
Investigating
We are currently investigating the issue. We apologise for the inconvenience.
Posted Dec 13, 2019 - 16:45 EET
This incident affected: Account Registration & Identification.