We’re fixing an issue with PDF access for invoices and receipts
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted Oct 14, 2024 - 15:32 EEST
Identified
We recently had an issue with accessing PDFs for invoices, order receipts, and other documents, except for newly created ones. This caused errors like blue screens and failed Dropbox exports.

We’ve identified the issue and are working on fixing it. It might take a little time for everything to be fully back to normal for all customers. Thanks for your patience, and we’ll keep you posted if anything changes.
Posted Oct 09, 2024 - 15:48 EEST
This incident affected: Holvi Web app and Holvi Mobile app.