Customers may experience problems in using the Osuuspankki payment button within the Holvi Online store and Instant Top-Up services
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted 8 months ago. Dec 14, 2018 - 16:29 EET
Identified
Customers may experience problems in using the Osuuspankki payment button within the Holvi Online store and Instant Top-Up services.
Posted 8 months ago. Dec 14, 2018 - 15:40 EET
This incident affected: Holvi Online store.