Users may experience longer than usual waiting times and technical issues while identifying themselves.
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved
Posted 12 months ago. Oct 19, 2018 - 16:09 EEST
Identified
We have identified an issue with our Identity Verification (KYC) provider. Our users from other markets than Finland and e-Estonia are facing longer than usual waiting times and technical issues while identifying themselves. We thank you for your patience and are investigating the cause of the issue together with our partner.
Posted about 1 year ago. Oct 12, 2018 - 10:45 EEST
This incident affected: Account Registration & Identification.