Issues with SEPA Instant payments processing

Incident Report for Holvi Payment Services Oy

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 18:46 EEST

Investigating

We are observing issues with SEPA Instant payments processing, and are actively looking into it. In the meantime, please use the standard SEPA payment method. We apologize for any inconvenience caused.
Posted Sep 26, 2025 - 15:35 EEST
This incident affected: SEPA Payments.