Delayed incoming SEPA payments
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted Dec 12, 2019 - 12:15 EET
Monitoring
All SEPA payments that should have arrived to Holvi’s accounts 6.12.2019 have been processed and redirected to the receiving accounts today. In case you are still missing a payment that was sent to Holvi on the 6th of December, please contact our support at support@holvi.com. We apologise for the any inconvenience this might have caused.
Posted Dec 11, 2019 - 17:01 EET
Update
We are continuing to investigate this issue.
Posted Dec 11, 2019 - 12:04 EET
Update
We are continuing to investigate this issue.
Posted Dec 11, 2019 - 09:07 EET
Investigating
We identified an issue that is causing a delay in processing some of our incoming SEPA payments that should have arrived to Holvi’s accounts 6.12.2019. We apologise for the issue and are currently working on resolving the issues as soon as possible.
Posted Dec 10, 2019 - 17:53 EET
This incident affected: SEPA Payments.