We’re investigating an issue with international transfers from the USA

Incident Report for Holvi Payment Services Oy

Resolved

This incident has been resolved.
Posted Aug 07, 2024 - 10:06 EEST

Investigating

We've noticed an issue with receiving payments from the USA. Our team is already looking into it to fix the issue. We appreciate your patience.
Posted May 13, 2024 - 14:24 EEST
This incident affected: International Payments.