Issues in processing Verification of Payee information for incoming payments to Finnish IBANs.

Incident Report for Holvi Payment Services Oy

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 12:33 EEST

Investigating

Our third-party provider is currently experiencing issues processing Verification of Payee information for incoming payments to Finnish IBANs. Please note that this error message does not prevent the payments from being completed. We are working together to resolve the issue as soon as possible and apologize for any inconvenience caused.
Posted Oct 09, 2025 - 08:57 EEST
This incident affected: SEPA Payments.