Users are temporarily unable to login via the browser
Incident Report for Holvi Payment Services Oy
Resolved
The issue has been resolved.
Posted 8 months ago. Feb 05, 2019 - 15:28 EET
Investigating
We are currently experiencing issues with login to the service. Our colleagues from the Product team are on it to solve the problem as quickly as possible.

Wir erfahren derzeit Probleme beim Login-Verfahren. Unsere Kollegen vom Produkt-Team arbeiten derzeit an einer Lösung. Danke für deine Geduld!
Posted 8 months ago. Feb 05, 2019 - 15:19 EET
This incident affected: Holvi Web app.