Customers may experience problems in using the Nordea payment button within the Holvi Online store and Instant Top-Up services
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted 9 months ago. Feb 01, 2019 - 13:00 EET
Identified
The issue has been identified and we are working towards a resolution together with our partner.
Posted 9 months ago. Feb 01, 2019 - 10:16 EET
This incident affected: Holvi Online store.