Some e-Resident users are experiencing problems using their Signicat Digi-ID card and reader
Incident Report for Holvi Payment Services Oy
Resolved
The underlying issue has been fixed and all e-Resident users should be able to use the Digi-ID card and reader without issues.
Posted 7 months ago. Jan 25, 2019 - 14:56 EET
Update
We are continuing to work on a fix for this issue.
Posted 7 months ago. Jan 24, 2019 - 14:33 EET
Identified
Some e-Resident users are experiencing problems using their Signicat Digi-ID card and reader. We are working on resolving the issue with the 3rd party provider
Posted 7 months ago. Jan 24, 2019 - 14:32 EET
This incident affected: Account Registration & Identification.