Holvi.com is down
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted Nov 14, 2019 - 14:30 EET
Investigating
Holvi.com com is currently down. We are investigating the issue. You are able to access your Holvi account by using the Holvi Mobile app.
Posted Nov 14, 2019 - 14:28 EET
This incident affected: Holvi Web app.