Unavailability with IDNow service
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 14:34 EET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2019 - 12:09 EET
Update
We are continuing to work on a fix for this issue.
Posted Nov 15, 2019 - 12:06 EET
Update
We are continuing to work on a fix for this issue.
Posted Nov 15, 2019 - 12:04 EET
Identified
We are currently experiencing unavailability with IDNow service. IDNow is investigating the issue with highest priority and all their available resources. This is affecting Holvi ID users.
Posted Nov 15, 2019 - 12:01 EET
This incident affected: Account Registration & Identification.