A small amount of Austrian and British customers are not able to complete name verification on Holvi Mobile app
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted Jun 12, 2020 - 16:00 EEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 12, 2020 - 12:58 EEST
Investigating
We are currently investigating the issue. We apologise for the inconvenience.
Posted Jun 11, 2020 - 16:45 EEST
This incident affected: Account Registration & Identification.