Holvi phone support currently unavailable
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 15:41 EET
Update
We are continuing to monitor for any further issues.
Posted Mar 16, 2020 - 15:32 EET
Monitoring
EN

We are sorry, until further notice our phone support is unavailable. We decided to follow the instructions and recommendations of the authorities in connection with the Covid-19 virus.
You can reach us as usual via our live chat in your Holvi account – just log in via browser and click on the help icon in the bottom right corner.
You can also send us a support request via support.holvi.com. We will get back to you as soon as possible. Thank you for your understanding and have a nice day!

FI

Valitettavasti puhelintukemme on toistaiseksi suljettu, johtuen viranomaisten ohjeistuksesta ja suosituksista Covid-19:n ehkäisyyn liittyen. Tavoitat meidät normaalisti chatin puolella – kirjaudu vain Holvi-tilillesi ja klikkaa Apua-painiketta oikeasta alakulmasta. Voit myös lähettää meille tukipyynnön osoitteessa support.holvi.com. Kiitos ymmärryksestä!

DE

Es tut uns leid, unser Telefonsupport ist derzeit und bis auf Weiteres nicht verfügbar, weil wir beschlossen haben, den Anordnungen und Empfehlungen der Behörden im Zusammenhang mit dem Coronavirus Folge zu leisten. Du erreichst uns weiterhin wie üblich über den Live-Chat. Du kannst uns ebenfalls eine Support-Anfrage senden via support.holvi.com. Besten Dank für dein Verständnis.
Posted Mar 16, 2020 - 09:15 EET
This incident affected: Holvi Support Phone.