Holvi Business Mastercard - Technical Issue
Incident Report for Holvi Payment Services Oy
Resolved
The technical issue with the Holvi Business Mastercard is now resolved. After monitoring the system for some time we can confirm it is now operating normally again.
Posted about 1 year ago. Aug 17, 2018 - 20:27 EEST
Identified
We are currently investigating this issue.
Posted about 1 year ago. Aug 17, 2018 - 16:43 EEST
This incident affected: Holvi Mastercard.