Duplicate payments in transaction view
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted Dec 04, 2019 - 14:53 EET
Identified
Due to a technical issue a verified outbound payment can be visible twice in the transaction feed of the desktop version in Holvi.

We are aware of the issue and we are working on a fix. Correct transactions can be checked from the account statement. The transaction feed will be corrected when refreshing the browser.
Posted Dec 04, 2019 - 12:10 EET
This incident affected: Holvi Web app.