Issues with login to Holvi service
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 12:59 EET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2020 - 11:06 EET
Identified
We are currently experiencing issues with login to the service. We are currently trying to solve the problem as quickly as possible.
Posted Feb 24, 2020 - 10:29 EET
This incident affected: Holvi Web app, Holvi Mobile app, and Holvi Online store.