Card Failures
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted 12 days ago. Jun 06, 2019 - 15:02 EEST
Investigating
EN
We identified an issue with the Holvi Business Mastercard that is causing some card payments to fail. We are working with our card processing partner to resolve the issue as soon as possible. We'll keep you updated!


DE
Wir haben ein Problem mit der Holvi Mastercard festgestellt, das dazu führt, dass einige Kartenzahlungen fehlschlagen. Unsere Kartenspezialisten arbeiten mit unserem Kartenverarbeitungspartner zusammen, um das Problem so schnell wie möglich zu beheben. Wir halten dich auf dem Laufenden und möchten uns für die entstandenen Unannehmlichkeiten entschuldigen!


FI
Olemme tunnistaneet ongelman jonka seurauksena osa Holvi Business Mastercard -kortilla tehdyistä maksuista on epäonnistunut. Tekninen osastomme on yhteydessä maksujen käsittelykumppaniin jotta tilanne saataisiin ratkaistua mahdollisimman pian. Pidämme teidät ajan tasalla!
Posted 12 days ago. Jun 06, 2019 - 14:43 EEST
This incident affected: Holvi Mastercard.