Holvi service unavailable
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 25, 2018 - 14:05 EEST
Identified
We identified an issue with the Holvi service that is currently unavailable. The issue may prevent you from accessing your Holvi account or the holvi.com website. Our engineering team is working to resolve the issue. We'll keep you updated!
Posted about 1 year ago. Jul 25, 2018 - 13:57 EEST
This incident affected: Holvi Web app and Holvi Mobile app.