German phone support down
Incident Report for Holvi Payment Services Oy
Resolved
This incident has been resolved.
Posted Aug 31, 2020 - 12:53 EEST
Investigating
Due to a technical problem we are currently not able to receive phonecalls to the standard German support line. Please contact us on the number +49 30 330 835111 until the problem is fixed.

Aufgrund eines technischen Problems können wir derzeit keine Anrufe auf die reguläre deutsche Support-Rufnummer erhalten. Wir sind telefonisch erreichbar unter +49 30 330 835111, via Live Chat oder das Kontaktformular in unserem Help Centre bis das Problem behoben wurde.
Posted Aug 31, 2020 - 12:42 EEST
This incident affected: Holvi Support Phone.